Patch PDF di Saurik: falla di sicurezza risolta per tutte le versioni di iOS

patch PDFAll'inizio della settimana, Apple aveva rilasciato un update di iOS per rimediare alla falla di sicurezza che permetteva di eseguire codice terzo nei dispositivi mobili. Proprio grazie a questa debolezza del sistema era stato possibile effettuare il jailbreak dell'iPhone via browser con JailbreakMe.

Gli aggiornamenti di iOS 4.0.2 e 3.2.2 che risolvono la falla nel motore PDF di Safari sono indirizzati agli iPhone 3G, iPhone 3GS, iPhone 4 e alle 2ª e 3ª generazione di iPod touch, nel primo caso, e agli iPad WiFi e iPad WiFi 3G nel secondo. Rimangono fuori le prime generazioni di iPhone e di iPod touch: l'ultima versione di iOS compatibile con questi dispositivi è iOS 3.1.3.

Ebbene, l'hacker Saurik ha reso disponibile un patch che risolve la falla di sicurezza di iOS anche per i dispositivi tralasciati da Apple. Il patch è è disponibile su Cydia ed è compatibile con tutte le versioni di iPhone OS, fino alla 2.x.

Il lato ironico della faccenda? Saurik fa parte del team che ha realizzato il jailbreak di iOS 4.

[Via AppleInsider|Immagine Dev-Team]

  • shares
  • Mail
1 commenti Aggiorna
Ordina: